WebdriverIO(Selenium or Appium) Chatbot Unavailable

Still not able to see this chat icon, but that’s maybe due to another language (german).

Anyway, the issue you are refering to is an issue with Webdriver (see https://github.com/webdriverio/webdriverio/issues/5699) , so what you are trying to do is currently not possible doing it this way.

  • You would have to overwrite the WEBDRIVERIO_OPENBOT capabilitiy to find an Appium-compatible way of doing it by coding the Webdriver-script yourself.
  • You could work on a PR for the Botium Webdriver connector to fix this Appium issue (see the above Webdriver github issue for possible solutions), or you wait for my team to work on this in the next sprints (if nothing higher priorized comes up)
  • Maybe the chatbot integrated into this app is a frontend for the chatbot on the Expedia website (https://www.expedia.com/service/) - in this case you could use Selenium instead of Appium for doing these tests

Hi @Florian,

Actually let me first show you what I have done in https://ibmsg.mini02.botiumbox.com/chatbots/view/cklxd8dbjqidi0763eh93zhmy which will be easy to you to let me know where I need to change in the Botium chatbot settings for this.

So the object locator for the chatbot icon that I have mentioned in the snap above is

Now using this, I have designed the settings as below to navigate to the chatbot widget.

Can you suggest what else I need to do to make this working? If you want, we can have a quick 5-10 mins webex as well.


You actually did everything right.

The issue is that for Appium this Navigation Button Selectors currently isn’t possible due to the mentioned Webdriver.io issue. This is something where a workaround in Botium connector code is needed.

Thanks for the clarifcation @Florian… one gentle request…would you kindly mind to please let me know the corresponding Botium connector code for this object locator please…then with that I can try running the same please and let you know the results…tnx

My first impression is that here is the place to start: https://github.com/codeforequity-at/botium-connector-webdriverio/blob/master/index.js#L116

I gave the code here:

Can you please help to fix this please. I think once this is fixed, then the rest is easy.

As written above, it is in the backlog and the team will work on it in one of the next sprints.

So @Florian in order to continue and proceed ahead with this Android app’s chatbot automation with Botium, what do you suggest please? Any recommendations?

Like written above:

  • Either wait for our team to work on it. Is is in our queue and will undergo our usual priorization process.
  • Or work on the fix yourself. We are happy to review and accept pull requests in our Github repos.

Okie understand…so @Florian just to understand correctly,for Mobile Apps, Botium will currently dont work on any app where the chatbot widget is not getting launched directly once the app is launched (like for this Expedia app), rather in the current scenerio Botium will only work where the chatbot widget is being launched directly on the app launch like this app (https://github.com/Hariofspades/ChatBot/blob/master/app/hari-bot.apk).
Kindly confirm my understanding please.

yes you are right

1 Like

Okie…so thts the reason why the Navigation Button Selectors is currently not working. Got it. Kindly let me know when your team will fix this please as I feel this is quite a important and must-to-have functionality to have for any app chatbots. Tnx.


Hi @Florian , hope you are doing fine. Just wanting to check on this, has this been already into Botium yet?

Yes, this has been solved recently

Fantastic @Florian …can you please extend the Sandbox environment Botium Box so that I can test this functionality please…also the Settings please so that I can test the Perfecto intergration to test this functionality…tnx

Please use the feature upgrade form in Box Mini to do this

Done. Can you please make the necessary changes in the Settings please

@Florian I am running now the same old Test Project Botium Box to test the Botium functionality, but getting the error now. Can you please check once.

The error is coming from Perfecto, “Failed to execute command handset obtain: No device was found”. Please check if the device is available for test execution on Perfecto

Yes I checked @Florian …it is available…also as a matter of fact, I have just now tested with another Perfecto device…but with same luck Botium Box
Can you kindly take a look into this please.