Problem with botium installation

Hi everybody! here again with some problems :frowning:

Steps:

  • brand new machine,

  • node installation
    node version v12.21.0
    npm version 6.14.11

  • botium-cli installation
    botium-cli -V 1.0.7

  • eco test works!!

  • watson-plugin installation:
    npm install botium-connector-watson and…

npm WARN deprecated axios@0.18.1: Critical security vulnerability fixed in v0.21.1. For more information, see https://gi
thub.com/axios/axios/pull/3410

bufferutil@4.0.3 install C:\botium\watson\node_modules\bufferutil
node-gyp-build

utf-8-validate@5.0.4 install C:\botium\watson\node_modules\utf-8-validate
node-gyp-build

npm WARN saveError ENOENT: no such file or directory, open ‘C:\botium\watson\package.json’
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN enoent ENOENT: no such file or directory, open ‘C:\botium\watson\package.json’
npm WARN botium-connector-watson@0.0.21 requires a peer of botium-core@^1.4.15 but none is installed. You must install p
eer dependencies yourself.
npm WARN watson No description
npm WARN watson No repository field.
npm WARN watson No README data
npm WARN watson No license field.

  • botium-connector-watson@0.0.21
    added 183 packages from 246 contributors and audited 183 packages in 38.942s

8 packages are looking for funding
run npm fund for details

found 1 high severity vulnerability
run npm audit fix to fix them, or npm audit for details

Please!! could you help me?
Seems to need a botium-core@^1.4.15 version installed and I don´t know what else todo.

Thanks in advnce!

This is only a warning from NPM telling you that without Botium Core the Botium Watson connector will not work. Botium Core is already included in Botium CLI, so you are safe.

Thanks for your answer. But look at this please:
I run the init command and in my directory there´s a simple curso.convo.txt file containing the same example that worked in the old machine.
And I´ve installed watson connector plugin…and also botium-cli emulator doesn´t work :frowning:

PS C:\botium\watson> botium-cli init
Botium Configuration File “./botium.json” already present, skipping …
Botium Convo File “C:\botium\watson\give_me_a_picture.convo.txt” already present, skipping …
Botium initialization ready. You should now run “botium-cli run --verbose --convos .” to verify.
PS C:\botium\watson> botium-cli run --convos .

Botium Test-Suite
1) “before all” hook for “curso.convo.txt”

0 passing (93ms)
1 failing

  1. Botium Test-Suite
    “before all” hook for “curso.convo.txt”:
    Error: Loading Botium Plugin failed.
    Loading Botium plugin from watson failed - Cannot find module ‘watson’
    Require stack:
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\node_modules\botium-core\src\containers\plugins\index.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\node_modules\botium-core\index.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\src\run\index.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\bin\botium-cli.js
    Loading Botium plugin botium-connector-watson failed, try “npm install botium-connector-watson” - Cannot find module ‘bo
    tium-core’
    Require stack:
  • C:\Users\AppData\Roaming\npm\node_modules\botium-connector-watson\dist\botium-connector-watson-cjs.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\node_modules\botium-core\src\containers\plugins\index.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\node_modules\botium-core\index.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\src\run\index.js
  • C:\Users\AppData\Roaming\npm\node_modules\botium-cli\bin\botium-cli.js
    at tryLoadPlugin (C:\Users\AppData\Roaming\npm\node_modules\botium-cli\node_modules\botium-core\src\contai
    ners\plugins\index.js:133:9)
    at PluginConnectorContainer.Validate (C:\Users\AppData\Roaming\npm\node_modules\botium-cli\node_modules\bo
    tium-core\src\containers\PluginConnectorContainer.js:14:27)

looking into it and get back

So the quick fix would be to install botium-core into global npm modules as well

npm install -g botium-core

Hello Florian!!
Thank you very much for your response! Now the eco works, but the two “demos” I created with Watson and kore.ai do not. I don’t have the former problem but now I get a
rest request failed: Error: connect ETIMEDOUT
and this must be an internal error due to our infraestructure.

I´m configuring botium to work from a private cloud with an Azure virtual machines and despite the machine gets connected to the internet using ie and chrome, the connection seems to be too slow (or something similar).
So, to me, the main problem gets now solved with your help. Thank you very much again and I´ll tell you when I finally make it all work.

Thanks again!!

1 Like